Mpls Örnek

R2#sh ip int brief | exclude down
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            10.10.10.2      YES manual up                    up  
FastEthernet2/0            20.20.20.2      YES manual up                    up  
Loopback0                  3.3.3.3         YES manual up                    up

R1#sh ip int brief | exc down
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            1.1.1.100       YES manual up                    up  
FastEthernet2/0            10.10.10.1      YES manual up                    up  
Loopback0                  2.2.2.2         YES manual up                    up  
 

R3#sh ip int brief | exc down
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            20.20.20.1      YES manual up                    up  
FastEthernet2/0            30.30.30.1      YES manual up                    up  
Loopback0                  4.4.4.4         YES manual up                    up  


R4#sh ip int brief | exclude down
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            30.30.30.2      YES manual up                    up  
FastEthernet2/0            6.6.6.100       YES manual up                    up  
Loopback0                  5.5.5.5         YES manual up                    up  



R1(config)#router eigrp 100
R1(config-router)#network 1.1.1.0 0.0.0.255
R1(config-router)#network 10.10.10.0 0.0.0.3
R1(config-router)#network 2.2.2.2 0.0.0.0
R1(config-router)#exit



R2(config)#router eigrp 100
R2(config-router)#network 10.10.10.0 0.0.0.3
*Jan 29 13:38:21.563: %DUAL-5-NBRCHANGE: EIGRP-IPv4 100: Neighbor 10.10.10.1 (FastEthernet0/0) is up: new adjacency
R2(config-router)#network 20.20.20.0 0.0.0.3
R2(config-router)#network 3.3.3.3 0.0.0.0



R2(config)#sh ip route

Gateway of last resort is not set

      1.0.0.0/24 is subnetted, 1 subnets
D        1.1.1.0 [90/30720] via 10.10.10.1, 00:07:44, FastEthernet0/0
      2.0.0.0/32 is subnetted, 1 subnets
D        2.2.2.2 [90/156160] via 10.10.10.1, 00:01:28, FastEthernet0/0
      3.0.0.0/32 is subnetted, 1 subnets
C        3.3.3.3 is directly connected, Loopback0
      10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        10.10.10.0/30 is directly connected, FastEthernet0/0
L        10.10.10.2/32 is directly connected, FastEthernet0/0
      20.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        20.20.20.0/30 is directly connected, FastEthernet2/0
L        20.20.20.2/32 is directly connected, FastEthernet2/0
R2#


R1#sh ip eigrp neighbors
EIGRP-IPv4 Neighbors for AS(100)
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq
                                                   (sec)         (ms)       Cnt Num
0   10.10.10.2              Fa2/0                    14 00:11:32   73   438  0  6
R1#

R4(config)#router eigrp 100
R4(config-router)#network 6.6.6.6 0.0.0.0
R4(config-router)#network 30.30.30.0 0.0.0.3
R4(config-router)#network 5.5.5.5 0.0.0.0

R3(config)#router eigrp 100
R3(config-router)#network 4.4.4.4 0.0.0.0
R3(config-router)#network 20.20.20.0 0.0.0.3
*Jan 29 13:50:30.595: %DUAL-5-NBRCHANGE: EIGRP-IPv4 100: Neighbor 20.20.20.2 (FastEthernet0/0) is up: new adjacency
R3(config-router)#network 30.30.30.0 0.0.0.3


R3#sh ip route

Gateway of last resort is not set

      1.0.0.0/24 is subnetted, 1 subnets
D        1.1.1.0 [90/33280] via 20.20.20.2, 00:02:16, FastEthernet0/0
      2.0.0.0/32 is subnetted, 1 subnets
D        2.2.2.2 [90/158720] via 20.20.20.2, 00:02:16, FastEthernet0/0
      3.0.0.0/32 is subnetted, 1 subnets
D        3.3.3.3 [90/156160] via 20.20.20.2, 00:02:16, FastEthernet0/0
      4.0.0.0/32 is subnetted, 1 subnets
C        4.4.4.4 is directly connected, Loopback0
      5.0.0.0/32 is subnetted, 1 subnets
D        5.5.5.5 [90/156160] via 30.30.30.2, 00:00:45, FastEthernet2/0
      10.0.0.0/30 is subnetted, 1 subnets
D        10.10.10.0 [90/30720] via 20.20.20.2, 00:02:16, FastEthernet0/0
      20.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        20.20.20.0/30 is directly connected, FastEthernet0/0
L        20.20.20.1/32 is directly connected, FastEthernet0/0
      30.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        30.30.30.0/30 is directly connected, FastEthernet2/0
L        30.30.30.1/32 is directly connected, FastEthernet2/0
R3#


R3#sh ip eigrp neighbors
EIGRP-IPv4 Neighbors for AS(100)
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq
                                                   (sec)         (ms)       Cnt Num
1   30.30.30.2              Fa2/0                    14 00:02:48   45   270  0  4
0   20.20.20.2              Fa0/0                    14 00:03:33   65   390  0  14
R3#



R1#sh ip eigrp neighbors
EIGRP-IPv4 Neighbors for AS(100)
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq
                                                   (sec)         (ms)       Cnt Num
0   10.10.10.2              Fa2/0                    14 00:16:42   57   342  0  13
R1#

R2#sh ip eigrp neighbors
EIGRP-IPv4 Neighbors for AS(100)
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq
                                                   (sec)         (ms)       Cnt Num
1   20.20.20.1              Fa2/0                    14 00:05:03   37   222  0  8
0   10.10.10.1              Fa0/0                    12 00:17:12   47   282  0  8
R2#


R3#sh ip eigrp neighbors
EIGRP-IPv4 Neighbors for AS(100)
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq
                                                   (sec)         (ms)       Cnt Num
1   30.30.30.2              Fa2/0                    13 00:04:38   45   270  0  4
0   20.20.20.2              Fa0/0                    11 00:05:22   65   390  0  14
R3#


R4#sh ip eigrp neighbors
EIGRP-IPv4 Neighbors for AS(100)
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq
                                                   (sec)         (ms)       Cnt Num
0   30.30.30.1              Fa0/0                    14 00:04:56 1360  5000  0  7
R4#

R1#sh ip eigrp topology
EIGRP-IPv4 Topology Table for AS(100)/ID(10.10.10.1)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 4.4.4.4/32, 1 successors, FD is 158720
        via 10.10.10.2 (158720/156160), FastEthernet2/0
P 5.5.5.5/32, 1 successors, FD is 161280
        via 10.10.10.2 (161280/158720), FastEthernet2/0
P 30.30.30.0/30, 1 successors, FD is 33280
        via 10.10.10.2 (33280/30720), FastEthernet2/0
P 20.20.20.0/30, 1 successors, FD is 30720
        via 10.10.10.2 (30720/28160), FastEthernet2/0
P 2.2.2.2/32, 1 successors, FD is 128256
        via Connected, Loopback0
P 3.3.3.3/32, 1 successors, FD is 156160
        via 10.10.10.2 (156160/128256), FastEthernet2/0
P 1.1.1.0/24, 1 successors, FD is 28160
        via Connected, FastEthernet0/0
P 10.10.10.0/30, 1 successors, FD is 28160
        via Connected, FastEthernet2/0

R1#



R1(config)#mpls label range 100 199
R1(config)#mpls ip
R1(config)#int fa0/0
R1(config-if)#mpls ip
R1(config-if)#exit
R1(config)#interface fa2/0
R1(config-if)#mpls ip
R1(config-if)#



R2(config)#mpls label range 200 299
R2(config)#interface fastEthernet 0/0
R2(config-if)#mpls ip
*Jan 29 14:03:01.455: %LDP-5-NBRCHG: LDP Neighbor 2.2.2.2:0 (1) is UP
R2(config)#interface fastEthernet 2/0
R2(config-if)#mpls ip

R3(config)#mpls label range 300 399
R3(config)#interface fa0/0
R3(config-if)#mpls ip
*Jan 29 14:04:54.431: %LDP-5-NBRCHG: LDP Neighbor 3.3.3.3:0 (1) is UP
R3(config)#interface fastEthernet 2/0
R3(config-if)#mpls ip

R4(config)#mpls label range 400 499
R4(config)#interface fastEthernet 0/0
R4(config-if)#mpls ip
R4(config-if)#exit
*Jan 29 14:06:03.287: %LDP-5-NBRCHG: LDP Neighbor 4.4.4.4:0 (1) is UP
R4(config)#interface fastEthernet 2/0
R4(config-if)#mpls ip



R1#sh mpls ldp bindings
  lib entry: 1.1.1.0/24, rev 2
        local binding:  label: imp-null
        remote binding: lsr: 3.3.3.3:0, label: 200
  lib entry: 2.2.2.2/32, rev 4
        local binding:  label: imp-null
        remote binding: lsr: 3.3.3.3:0, label: 201
  lib entry: 3.3.3.3/32, rev 6
        local binding:  label: 100
        remote binding: lsr: 3.3.3.3:0, label: imp-null
  lib entry: 4.4.4.4/32, rev 8
        local binding:  label: 101
        remote binding: lsr: 3.3.3.3:0, label: 202
  lib entry: 5.5.5.5/32, rev 10
        local binding:  label: 102
        remote binding: lsr: 3.3.3.3:0, label: 203
  lib entry: 10.10.10.0/30, rev 12
        local binding:  label: imp-null
        remote binding: lsr: 3.3.3.3:0, label: imp-null
  lib entry: 20.20.20.0/30, rev 14
        local binding:  label: 103
        remote binding: lsr: 3.3.3.3:0, label: imp-null
  lib entry: 30.30.30.0/30, rev 16
        local binding:  label: 104
        remote binding: lsr: 3.3.3.3:0, label: 204
R1#


R1# sh mpl ldp bindings local
  lib entry: 1.1.1.0/24, rev 2
        local binding:  label: imp-null
  lib entry: 2.2.2.2/32, rev 4
        local binding:  label: imp-null
  lib entry: 3.3.3.3/32, rev 6
        local binding:  label: 100
  lib entry: 4.4.4.4/32, rev 8
        local binding:  label: 101
  lib entry: 5.5.5.5/32, rev 10
        local binding:  label: 102
  lib entry: 10.10.10.0/30, rev 12
        local binding:  label: imp-null
  lib entry: 20.20.20.0/30, rev 14
        local binding:  label: 103
  lib entry: 30.30.30.0/30, rev 16
        local binding:  label: 104
R1#


R2#sh mpls ldp bindings all
  lib entry: 1.1.1.0/24, rev 2
        local binding:  label: 200
        remote binding: lsr: 2.2.2.2:0, label: imp-null
        remote binding: lsr: 4.4.4.4:0, label: 300
  lib entry: 2.2.2.2/32, rev 4
        local binding:  label: 201
        remote binding: lsr: 2.2.2.2:0, label: imp-null
        remote binding: lsr: 4.4.4.4:0, label: 301
  lib entry: 3.3.3.3/32, rev 6
        local binding:  label: imp-null
        remote binding: lsr: 2.2.2.2:0, label: 100
        remote binding: lsr: 4.4.4.4:0, label: 302
  lib entry: 4.4.4.4/32, rev 8
        local binding:  label: 202
        remote binding: lsr: 2.2.2.2:0, label: 101
        remote binding: lsr: 4.4.4.4:0, label: imp-null
  lib entry: 5.5.5.5/32, rev 10
        local binding:  label: 203
        remote binding: lsr: 2.2.2.2:0, label: 102
        remote binding: lsr: 4.4.4.4:0, label: 303
  lib entry: 10.10.10.0/30, rev 12
        local binding:  label: imp-null
        remote binding: lsr: 2.2.2.2:0, label: imp-null
        remote binding: lsr: 4.4.4.4:0, label: 304
  lib entry: 20.20.20.0/30, rev 14
        local binding:  label: imp-null
        remote binding: lsr: 2.2.2.2:0, label: 103
        remote binding: lsr: 4.4.4.4:0, label: imp-null
  lib entry: 30.30.30.0/30, rev 16
        local binding:  label: 204
        remote binding: lsr: 2.2.2.2:0, label: 104
        remote binding: lsr: 4.4.4.4:0, label: imp-null
R2#

R3#sh mpls ldp bindings all
  lib entry: 1.1.1.0/24, rev 2
        local binding:  label: 300
        remote binding: lsr: 3.3.3.3:0, label: 200
        remote binding: lsr: 5.5.5.5:0, label: 400
  lib entry: 2.2.2.2/32, rev 4
        local binding:  label: 301
        remote binding: lsr: 3.3.3.3:0, label: 201
        remote binding: lsr: 5.5.5.5:0, label: 401
  lib entry: 3.3.3.3/32, rev 6
        local binding:  label: 302
        remote binding: lsr: 3.3.3.3:0, label: imp-null
        remote binding: lsr: 5.5.5.5:0, label: 402
  lib entry: 4.4.4.4/32, rev 8
        local binding:  label: imp-null
        remote binding: lsr: 3.3.3.3:0, label: 202
        remote binding: lsr: 5.5.5.5:0, label: 403
  lib entry: 5.5.5.5/32, rev 10
        local binding:  label: 303
        remote binding: lsr: 3.3.3.3:0, label: 203
        remote binding: lsr: 5.5.5.5:0, label: imp-null
  lib entry: 6.6.6.0/24, rev 17
        remote binding: lsr: 5.5.5.5:0, label: imp-null
  lib entry: 10.10.10.0/30, rev 12
        local binding:  label: 304
        remote binding: lsr: 3.3.3.3:0, label: imp-null
        remote binding: lsr: 5.5.5.5:0, label: 404
  lib entry: 20.20.20.0/30, rev 14
        local binding:  label: imp-null
        remote binding: lsr: 3.3.3.3:0, label: imp-null
        remote binding: lsr: 5.5.5.5:0, label: 405
  lib entry: 30.30.30.0/30, rev 16
        local binding:  label: imp-null
        remote binding: lsr: 3.3.3.3:0, label: 204
        remote binding: lsr: 5.5.5.5:0, label: imp-null
R3#

R4#sh mpls ldp bindings all
  lib entry: 1.1.1.0/24, rev 2
        local binding:  label: 400
        remote binding: lsr: 4.4.4.4:0, label: 300
  lib entry: 2.2.2.2/32, rev 4
        local binding:  label: 401
        remote binding: lsr: 4.4.4.4:0, label: 301
  lib entry: 3.3.3.3/32, rev 6
        local binding:  label: 402
        remote binding: lsr: 4.4.4.4:0, label: 302
  lib entry: 4.4.4.4/32, rev 8
        local binding:  label: 403
        remote binding: lsr: 4.4.4.4:0, label: imp-null
  lib entry: 5.5.5.5/32, rev 10
        local binding:  label: imp-null
        remote binding: lsr: 4.4.4.4:0, label: 303
  lib entry: 6.6.6.0/24, rev 12
        local binding:  label: imp-null
  lib entry: 10.10.10.0/30, rev 14
        local binding:  label: 404
        remote binding: lsr: 4.4.4.4:0, label: 304
  lib entry: 20.20.20.0/30, rev 16
        local binding:  label: 405
        remote binding: lsr: 4.4.4.4:0, label: imp-null
  lib entry: 30.30.30.0/30, rev 18
        local binding:  label: imp-null
        remote binding: lsr: 4.4.4.4:0, label: imp-null
R4#

R4#sh mpls ldp bindings local
  lib entry: 1.1.1.0/24, rev 2
        local binding:  label: 400
  lib entry: 2.2.2.2/32, rev 4
        local binding:  label: 401
  lib entry: 3.3.3.3/32, rev 6
        local binding:  label: 402
  lib entry: 4.4.4.4/32, rev 8
        local binding:  label: 403
  lib entry: 5.5.5.5/32, rev 10
        local binding:  label: imp-null
  lib entry: 6.6.6.0/24, rev 12
        local binding:  label: imp-null
  lib entry: 10.10.10.0/30, rev 14
        local binding:  label: 404
  lib entry: 20.20.20.0/30, rev 16
        local binding:  label: 405
  lib entry: 30.30.30.0/30, rev 18
        local binding:  label: imp-null
R4#


R3#sh mpls ldp bindings local
  lib entry: 1.1.1.0/24, rev 2
        local binding:  label: 300
  lib entry: 2.2.2.2/32, rev 4
        local binding:  label: 301
  lib entry: 3.3.3.3/32, rev 6
        local binding:  label: 302
  lib entry: 4.4.4.4/32, rev 8
        local binding:  label: imp-null
  lib entry: 5.5.5.5/32, rev 10
        local binding:  label: 303
  lib entry: 10.10.10.0/30, rev 12
        local binding:  label: 304
  lib entry: 20.20.20.0/30, rev 14
        local binding:  label: imp-null
  lib entry: 30.30.30.0/30, rev 16
        local binding:  label: imp-null
R3#
R2#sh mpls ldp bindings local
  lib entry: 1.1.1.0/24, rev 2
        local binding:  label: 200
  lib entry: 2.2.2.2/32, rev 4
        local binding:  label: 201
  lib entry: 3.3.3.3/32, rev 6
        local binding:  label: imp-null
  lib entry: 4.4.4.4/32, rev 8
        local binding:  label: 202
  lib entry: 5.5.5.5/32, rev 10
        local binding:  label: 203
  lib entry: 10.10.10.0/30, rev 12
        local binding:  label: imp-null
  lib entry: 20.20.20.0/30, rev 14
        local binding:  label: imp-null
  lib entry: 30.30.30.0/30, rev 16
        local binding:  label: 204
R2#


R1#sh mpls ldp bindings local
  lib entry: 1.1.1.0/24, rev 2
        local binding:  label: imp-null
  lib entry: 2.2.2.2/32, rev 4
        local binding:  label: imp-null
  lib entry: 3.3.3.3/32, rev 6
        local binding:  label: 100
  lib entry: 4.4.4.4/32, rev 8
        local binding:  label: 101
  lib entry: 5.5.5.5/32, rev 10
        local binding:  label: 102
  lib entry: 10.10.10.0/30, rev 12
        local binding:  label: imp-null
  lib entry: 20.20.20.0/30, rev 14
        local binding:  label: 103
  lib entry: 30.30.30.0/30, rev 16
        local binding:  label: 104
R1#


Last updated